Results 1 to 7 of 7

Thread: Java SmartDashboard not launching

  1. #1
    Join Date
    Feb 2016
    Posts
    4

    Default Java SmartDashboard not launching

    Our team's smartdashboard is not launching when we open the DS. Any suggestions?

  2. #2
    Join Date
    Oct 2011
    Posts
    551

    Default Re: Java SmartDashboard not launching

    The Java Smartdashboard is installed by the Eclipse plugins. Make sure you have Eclipse and the plugins installed on the machine, and that you have run Eclipse with the plugins on the same user account the DS is running from. Alternately, you can copy the SmartDashboard jar file from "C:\Users\USERNAME\wpilib\tools" from a computer with the Eclipse plugin to the equivalent location on the machine running the DS.

    If you do have the Eclipse plugins installed and the SmartDashboard is still not launching, it is likely an issue with Java versions. Try running the SmartDashboard manually by double-clicking on the jar file or, preferably, by using a command prompt window. If this works and the DS launching doesn't you likely have multiple versions of Java installed, try removing old versions and see if that resolves the issue. If you cannot launch it manually, try downloading and installing the latest version of Java.
    FIRST
    FRC Robotics Engineer

  3. #3
    Join Date
    Feb 2016
    Posts
    4

    Default Re: Java SmartDashboard not launching

    Okay. That would make sense, because the DS computer is not running eclipse...

    So it should fix the issue if I copy the SmartDashoard.jar file and move it to the native location on the DS computer?

  4. #4
    Join Date
    Oct 2011
    Posts
    551

    Default Re: Java SmartDashboard not launching

    Correct, if you have the right JRE (Java Runtime Environment) installed on the DS and you copy that file to C:\Users\USERNAME\wpilib\tools it should work properly.
    FIRST
    FRC Robotics Engineer

  5. #5
    Join Date
    Feb 2016
    Posts
    4

    Default Re: Java SmartDashboard not launching

    Okay, thanks for your help.

  6. #6
    Join Date
    Aug 2016
    Posts
    1

    Default Re: Java SmartDashboard not launching

    How do i make sure the eclipse plugin is installed and it is the right versions?

  7. #7
    Join Date
    Oct 2011
    Posts
    551

    Default Re: Java SmartDashboard not launching

    The installed version of the Eclipse plugins can be checked by selecting Help->Installation Details then clicking the Installed Software tab and looking for "Robot Java Development" or "Robot C++ Development". The current latest version is 2017.3.1
    FIRST
    FRC Robotics Engineer

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. R12 Launching
    By timisw in forum Rules & Missions
    Replies: 5
    Last Post: 11-25-2015, 04:05 PM
  2. Replies: 2
    Last Post: 02-16-2015, 12:22 AM
  3. Replies: 1
    Last Post: 02-06-2015, 09:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •