Results 1 to 7 of 7

Thread: USB Camera is not working on the new 2017 Firmware.

  1. #1
    Join Date
    Feb 2017
    Posts
    3

    Question USB Camera is not working on the new 2017 Firmware.

    The USB camera is not working on the Drive station.

    The RoboRIO is working. The USB camera is showing on the Interface and the camera is showing up on the Drive-station.


    I have tried the following things to fix it:
    1. Reformatting the roboRIO from the FRC_roboRIO_2017_v8.zip Imaging tool
    2. Uploading the 2017 robot project.
    3. Replacing the roboRIO from our other robot.

    RoboRIO Firmware Version: 3.0.0f0
    RoboRIO Image Version: FRC_roboRIO_2017_v8
    DriveStation: 17.0a.111

    I get the camera name show up on the Drop-down on the Drive-station and I see the camera on the NI RoboRIO Web interface but I do NOT get a Feed on the Dashboard.

    Last Month I mad a post on CD about no Camera showing up on my old robot but that was because it was old roboRIO code (New Lib)

    --------------------------------------------------

    Also I would like to know how do you make the drive-station accept a different camera other than the Axis-Camera. I have taken a look at all of the libs included in making the feed goto the Camera Display Object but I don't know specifically what to Edit in all. I have seen that it uses a lot of WPI libs.... I have already have seen what URLs, IPs, and Params set and to be changed to work but I'm not entirely sure!

  2. #2
    Join Date
    Oct 2011
    Posts
    551

    Default Re: USB Camera is not working on the new 2017 Firmware.

    Welcome to the FIRST Forums! Greg McKaskle from NI is currently investigating a very similar sounding issue. I will point him this way and see if he has any suggestions or info he may want from your setup.
    FIRST
    FRC Robotics Engineer

  3. #3
    Join Date
    Sep 2008
    Posts
    86

    Default Re: USB Camera is not working on the new 2017 Firmware.

    The things I'd check are...
    Firewall : The camera server operates on port 1181, so you should verify the firewalls are turned off, or if you are really confident in what you are doing, you can make a rule to allow incoming and outgoing traffic. This can be accessed in Control Panel and search for disable firewall.
    Additional network interfaces: I have seen cases where the DS can connect to the robot, but where other connections fail. This is because they are not using mDNS, but are relying on Windows normal address name resolution. I've seen this improve when disabling wifi. Similarly, you may want to disconnect a wired Ethernet if that is to another network.

    You may also want to click to the Variables tab of the Dashboard. At the top, the cameras will be listed along with the address that it is trying to talk to. Clearly, if that address is not correct, that is part of the problem.

    Greg McKaskle

  4. #4
    Join Date
    Feb 2017
    Posts
    3

    Default Re: USB Camera is not working on the new 2017 Firmware.

    (This fix applies to our older robot that has the newer roboRIO and the 2017 Updates and up-to-date Programming for LabVIEW.)

    Ok, I did some updates to the Drive-station and LabVIEW.
    With the Updates the System does recognize the Camera. (Note: I is slow at getting the list of cameras)
    Also the drive-station Only Shows 1 USB Camera when 2 are connected. (I hope we don't use both USB camera's but I need to keep the door open.)

    I didn't need to do any things with the ports or any reformatting of the RoboRIO.

    So the update has seemed to have fixed the USB Camera Issue. It had to of been a Dashbaord issue considering that the Camera would show up in the list but no feed (Image) would show up.

  5. #5
    Join Date
    Oct 2011
    Posts
    551

    Default Re: USB Camera is not working on the new 2017 Firmware.

    Quote Originally Posted by nhalstead View Post
    Also the drive-station Only Shows 1 USB Camera when 2 are connected. (I hope we don't use both USB camera's but I need to keep the door open.)
    You will likely have to reduce the resolution/framerate of the first camera you are opening to allow for enough USB bandwidth for the second open to succeed.
    FIRST
    FRC Robotics Engineer

  6. #6
    Join Date
    Feb 2017
    Posts
    3

    Default Re: USB Camera is not working on the new 2017 Firmware.

    Ok. I'm still getting the same errors and problems. I am unable to receive a Camera Feed. I get a Camera option show up in the drop down list but I am NOT getting any feedback.

    In RobotMain.vi -> "WPI_CameraSend Images to PC" -> TCP Listion Object has an Erro of:
    Error 56 occurred at TCP Wait On Listener in TCP Listen.vi:7210001->WPI_CameraSend Images To PC Loop.vi->Robot Main.vi
    Sends "mjpg:http://roboRIO-5420-FRC:1181/stream.mjpg?name=Camera" to "/CameraPublisher/Camera/streams"
    Sends "usb:IMAQdx/cam0" to "/CameraPublisher/Camera/source"


    Other Errors:
    <LOCATION>WPI_CameraIssue HTTP Request with Authentication.vi<CALLSTACK>WPI_CameraIssue HTTP Request with Authentication.vi< <WPI_CameraIPCameraRead.vi:7140007< <WPI_CameraGet Image From Controller.vi:2210003< <WPI_CameraRead MJPG for Dashboard.vi:3780002< <Dashboard Main.vi


    ```LabVIEW Error

    Error -44003 occurred at <LOCATION>WPI_CameraIssue HTTP Request with Authentication.vi<CALLSTACK>WPI_CameraIssue HTTP Request with Authentication.vi< <WPI_CameraIPCameraRead.vi:7140007< <WPI_CameraGet Image From Controller.vi:2210003< <WPI_CameraRead MJPG for Dashboard.vi:3780002< <Dashboard Main.vi

    Possible reason(s):

    FRC: Operation failed due to a communication failure with the camera.
    ```
    Attached Images Attached Images

  7. #7
    Join Date
    Sep 2008
    Location
    Wyndmoor, pa
    Posts
    4

    Default Re: USB Camera is not working on the new 2017 Firmware.

    423 still blind using USB camera.
    This worked at home during the build season but not on the field.
    We installed two updates given to us by the FTAs at our first event with no joy.
    Is there a location for up-to-date info from National Instruments or Labview ?
    We feel not only blind but cut off from the sources of recent updates.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FRCSim 2017 Field
    By nickluther in forum Game Simulation Software
    Replies: 4
    Last Post: 03-27-2017, 05:56 AM
  2. 2017 wf
    By dna1990 in forum Miscellaneous
    Replies: 8
    Last Post: 04-10-2015, 01:38 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •