Announcement

Collapse
No announcement yet.

Program won't run, stuck loading on brick

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Program won't run, stuck loading on brick

    My students have written a program and downloaded it to their brick. When they try to run the program the screen says program with the loading bar but it never runs. When I run the demo that runs. We have updated firmware, done a hard reset, and tried using a different brick. This happened to another group, but when we did a hard reset and ran the demo then the program worked. I tried to search for answer but am having a hard time finding anything. Any advice would be appreciated! I

  • #2
    What software are you using, the one that runs on tablets and chromebook (my guess) or the one that runs on desktops and laptops? Can you post your program here?

    Comment


    • #3
      We are running on a windows laptop the lego mindstorms block programming.

      Comment


      • #4
        I don't understand what you mean by "the screen says program with the loading bar but it never runs". I don't think I've ever seen a "loading bar". When I press run I get a "MINDSTORMS" banner with a bar and a kind of progress indicator that glides from left to right over and over, and under the bar it says the name of the program that is running. The button lamps also flash on and off (green if the batteries are changed, yellow if you need a charge). This is what I expect to see when I run a program unless the program has blocks to change the brick button lamps or draw on the display. Is this similar to what you are seeing? If so, your program is running, it just may not do what you expect. Maybe you are trying to move a motor that isn't attached, or one that is stalled. Pressing the back button (is that what you mean by a hard reset?) exits the program.

        Comment


        • #5
          Could be a wire is not fully connected, or a wire/sensor/motor has gone bad. Try unplugging and re-plugging all wires. Try a really simple program for each motor and sensor. If the program is waiting for a response from a motor or sensor and not getting any, it may sit there on PROGRAM RUNNING waiting for the feedback that is not coming.

          Also try new / recharged battery.

          Comment

          Working...
          X