Announcement

Collapse
No announcement yet.

EV3 brick error when running program after robot boot but not after program download

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • EV3 brick error when running program after robot boot but not after program download

    My team is running into an error we have not seen or heard of before and are hoping someone has some insights.
    We have a program in a project which has been running on multiple robots without issue for a number of weeks. Now when we boot the robot and run this specific program it gives an error on the brick (just says error with a check box) and will not run. However when we download the program (with no changes) after the robot boots it runs without issue. This is a repeatable issue. It happens on multiple robots. It happens after computer reboots and robot reboots. We are running with firmware v1.09H. This is the only project on the robot. We are using an older computer (running Windows XP...don
    --
    Fort Worth Robotics - North Texas Region Team #455
    Technical coach, baker of the cookies, keeper of the time, transporter of the travel field walls, finder of the spare parts, maker of the pop culture references that only the other tall people understand.

  • #2
    I've gotten errors like that when we copy code from one computer to another because a myblock from one computer isn't on the other. Does that program call a myblock that maybe isn't there?

    Comment


    • #3
      No My blocks, but I think there may be a sound file. Wonder if that could be missing and causing the problem.
      --
      Fort Worth Robotics - North Texas Region Team #455
      Technical coach, baker of the cookies, keeper of the time, transporter of the travel field walls, finder of the spare parts, maker of the pop culture references that only the other tall people understand.

      Comment


      • #4
        There are no my blocks on the EV3. The blocks are compiled into the program files that are downloaded.

        Missing sound files result in missing sounds, not a crash. Missing image files work much the same way. No image is drawn and the program doesn't crash. A missing file opened by the program (file read) will crash the program, but you get a different error (File Read Error). You can also crash a program doing an array read. This has no message, only the caution sign, an image I think is supposed to represent an array, and the check box.

        What happens if you copy your project under a different name and download both? Do both projects crash?
        Last edited by Dean Hystad; 01-13-2019, 10:53 AM.

        Comment


        • #5
          Originally posted by Tim Carey View Post
          I've gotten errors like that when we copy code from one computer to another because a myblock from one computer isn't on the other. Does that program call a myblock that maybe isn't there?
          If you are missing a my block on the laptop you'll get an error when you try to download (Unable to compile). It does not create a program on the EV3 that crashes.
          Last edited by Dean Hystad; 01-13-2019, 10:44 AM.

          Comment


          • #6
            Oh yeah... That is what had happened...

            Comment


            • #7
              Originally posted by Dean Hystad View Post
              What happens if you copy your project under a different name and download both? Do both projects crash?
              Haven't been able to try that (ran out of time for more troubleshooting on Saturday) but we will try that.

              What's most puzzling to me is why we were able to download the program and run it without issue but, once we rebooted the robot, without making any changes to anything other than cycling the power, we would get the crash. Downloading the program, again with no changes, fixed the issue. So that tells me that, most likely, this is not an issue with a file missing. Also, with it happening on multiple robots, this is not a robot specific issue.

              --
              Fort Worth Robotics - North Texas Region Team #455
              Technical coach, baker of the cookies, keeper of the time, transporter of the travel field walls, finder of the spare parts, maker of the pop culture references that only the other tall people understand.

              Comment


              • #8
                Originally posted by gt0163c View Post

                Haven't been able to try that (ran out of time for more troubleshooting on Saturday) but we will try that.

                What's most puzzling to me is why we were able to download the program and run it without issue but, once we rebooted the robot, without making any changes to anything other than cycling the power, we would get the crash. Downloading the program, again with no changes, fixed the issue. So that tells me that, most likely, this is not an issue with a file missing. Also, with it happening on multiple robots, this is not a robot specific issue.
                If you post the program I will take a look at it.

                Does the program continue to run OK until you cycle power on the brick or does it only run after a download?
                Last edited by Dean Hystad; 01-14-2019, 01:07 PM.

                Comment


                • #9
                  This problem was also posted on the FLL: Share and Learn Facebook Group yesterday. We took a look at the code. Symptoms exists in both Home and Education firmware. The code will not not play from the Recent menu, but will from Programs or when Downloaded. We managed to fix the issue for them. Their program name is very long. If you change it and make it shorter, it works fine. Didn't have time to investigate exactly how long the name can be before it crashes, but at least the team can move forward.

                  This is probably a bug that needs to be reported to LEGO.
                  **************************
                  EV3Lessons.com and FLLTutorials.com Founders
                  FLL #51 World Festival Champion's 2018 (retired)
                  FRC Not the Droids You Are Looking For (Rookie season 2020)

                  Comment

                  Working...
                  X