Announcement

Collapse
No announcement yet.

Problems with axis camera setup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with axis camera setup

    Hi. We received our early kit friday, and we are having some problems with "setup axis camera". We keep getting a message of:

    "unable to complete operation because of unexpected error %d: %s 59 TCP open connection in axis Issue http request with authentication. vi-> axis issue get.vi-> axis create FRC user.vi-> dialog.vi"

    We went through all the steps in chapter 5, including setting our static IP address to 192.168.0.90 and we are still getting the same message.

    If someone can give team 2054 a little help it would be greatly appreciated.
    Team 2054 "Viking Robotix"
    Hopkins High School, Hopkins, MI
    Head Electrical/Programming mentor

  • #2
    Re: Problems with axis camera setup

    What are you doing when you get this error message? It sounds like it is a LabVIEW message, are you running an example program on the cRIO? Which one?

    After you complete the configuration of the camera in section 5.6, you should plug the camera into port 2 of the cRIO.
    Team 330 beta tester

    Comment


    • #3
      Re: Problems with axis camera setup

      Originally posted by electricman View Post
      "unable to complete operation because of unexpected error %d: %s 59 TCP open connection in axis Issue http request with authentication. vi-> axis issue get.vi-> axis create FRC user.vi-> dialog.vi"

      We went through all the steps in chapter 5, including setting our static IP address to 192.168.0.90 and we are still getting the same message.
      I received the same error message from the camera setup program.
      I was confused by this because the camera documentation says that it is at that address. I changed the computer to .91 and got a different error message. I disabled my firewall and the operation completed OK.
      I'm not sure if changing the address was necessary or not, but check your firewall.
      Last edited by Rwood359; 12-09-2008, 03:53 PM. Reason: clarification

      Comment


      • #4
        Re: Problems with axis camera setup

        Nope, we are just doing the Manual Setup Axis Camera in chapter 5.5.1.

        We seem to be stuck here:

        "5. If a “Configure Root Password” dialog box pops up, enter the username "root" and the password
        "pass".

        This box won't show up to configure the password.
        We also can't seem to navigate to the camera using:

        "4. Navigate your web browser to http://192.168.0.90/."

        It keeps telling me I can't work on it offline. Web Page Unavailable.

        The ethernet crossover seems to be working because the computer recognizes that there is a "Local Area Connection 100mbs" anytime we plug the camera in.
        Team 2054 "Viking Robotix"
        Hopkins High School, Hopkins, MI
        Head Electrical/Programming mentor

        Comment


        • #5
          Re: Problems with axis camera setup

          I'll check the Firewall tonight. thank you.
          Team 2054 "Viking Robotix"
          Hopkins High School, Hopkins, MI
          Head Electrical/Programming mentor

          Comment


          • #6
            Re: Problems with axis camera setup

            I'm not an ethernet expert, but how does it work to have both the camera and PC at 192.168.0.90?

            Comment


            • #7
              Re: Problems with axis camera setup

              You should not set your computers ip address to .90. It needs to be something different, like .91 that Randy used or .6 like the example in the documentation.

              I'm surprised that windows did not complain about duplicate IP addresses. Are you sure you are actually setting the IP address. If you open a command prompt and run ipconfig, does it show the ip address you set? One you get that set correctly, if it still complains about working offline, be sure to tell it to connect.

              Originally posted by Rwood359 View Post
              I'm not an ethernet expert, but how does it work to have both the camera and PC at 192.168.0.90?
              It shouldn't work. I missed that at first. Good catch.
              Team 330 beta tester

              Comment


              • #8
                Re: Problems with axis camera setup

                Originally posted by jross View Post
                You should not set your computers ip address to .90. It needs to be something different, like .91 that Randy used or .6 like the example in the documentation.

                I'm surprised that windows did not complain about duplicate IP addresses. Are you sure you are actually setting the IP address. If you open a command prompt and run ipconfig, does it show the ip address you set? One you get that set correctly, if it still complains about working offline, be sure to tell it to connect.



                It shouldn't work. I missed that at first. Good catch.
                I'll also try that thank you. I'll let you know what i find.
                Team 2054 "Viking Robotix"
                Hopkins High School, Hopkins, MI
                Head Electrical/Programming mentor

                Comment


                • #9
                  Re: Problems with axis camera setup

                  Originally posted by jross View Post
                  You should not set your computers ip address to .90. It needs to be something different, like .91 that Randy used or .6 like the example in the documentation.
                  It depends on which example you look at.
                  The problem is that the FRC Programming Guide Section 3 says to set the PC address to .90.
                  I post it in the documentation thread.

                  Comment


                  • #10
                    Re: Problems with axis camera setup

                    Where are you seeing instructions that tell you to set the PC address to .90?

                    If you want to talk to the camera directly just do this:

                    1. Set your PC IP address to 192.168.0.xx where xx is anything BUT 90.
                    2. Connect camera to that ethernet port using crossover cable
                    3. open browser and goto 192.168.0.90.

                    Does that work?

                    Comment


                    • #11
                      Re: Problems with axis camera setup

                      Originally posted by rfolea View Post
                      Where are you seeing instructions that tell you to set the PC address to .90?
                      The FRC Programming Guide
                      http://decibel.ni.com/content/docs/DOC-2631
                      Page 3-2
                      For whatever reason, I used that guide and it cost me some time to figure out the problem. I was pointing out the error for others.

                      Comment


                      • #12
                        Re: Problems with axis camera setup

                        I can set up the camera to function when connected directly to my computer. How do I communicate with the camera when it is hooked up to cRIO port 2? I am able to ping cRIO port #1 (10.xx.yy.2) but I am unable to ping cRIO port #2 (192.168.0.3) or communicate with the camera.

                        Comment


                        • #13
                          Re: Problems with axis camera setup

                          Originally posted by Randylevering View Post
                          I can set up the camera to function when connected directly to my computer. How do I communicate with the camera when it is hooked up to cRIO port 2? I am able to ping cRIO port #1 (10.xx.yy.2) but I am unable to ping cRIO port #2 (192.168.0.3) or communicate with the camera.
                          Once it's connected to the cRIO, your PC won't be able to see it directly. You need to run a program on the cRIO. The default LabVIEW code process the data and sends it to the dashboard, if enabled (not sure about C++). There are examples for using the camera with both programming environments.

                          Hope that helps.
                          Team 330 beta tester

                          Comment


                          • #14
                            Re: Problems with axis camera setup

                            O.K. first off thank you to everyone who replied. All of your advice has been very helpful.
                            Second, sorry for not posting back sooner, I haven't been able to get to my desk the last few days.

                            Now the problem I was having. It turned out that disabling the Firewall helped. I also was having problems with my network bridge not being properly set. After running the network setup wizard (3 times) and disabling the firewall, we finally got the laptop to communicate with the camera. We are now up and running.

                            Now on another topic, I'm loving the new system but, I can't wait for the instruction manual(s) to be revised. It seems that some of the "pointing" suggestions could be cleared up (like section 3.2 "setting the IP address", and also the driver station firmware update refering to name the file DSUB_PKG.BIN not DSUB_PKG).

                            I'm sure that these matters will be cleaned up soon. After all, with the new system, we are all guiney pigs this year and I know it takes a lot of time and educated trial and error steps to develop good new systems.

                            Again thank you to everyone.
                            Team 2054 "Viking Robotix"
                            Hopkins High School, Hopkins, MI
                            Head Electrical/Programming mentor

                            Comment


                            • #15
                              Re: Problems with axis camera setup

                              The orange cable that came in the KOP is a crossover cable.
                              The cRIO does not have autosense, so it must be connected to the camera via the crossover cable. Your PC may have autosense, if so it would work with either type of cable. I took this from chief delphi, it helped me.

                              Comment

                              Working...
                              X